Essentials of Community Cybersecurity (AWR-136) (04-20-0136) - 005

You are not signed in. Enrollments for this event require you to sign in with a valid New York Division of Homeland Security and Emergency Services account that has permission to request enrollment.
Brief Description
The course provides an intro to cybersecurity vulnerabilities, risks, threats, & countermeasures.
Full Description
Description:
The Essentials of Community Cybersecurity (ECCS) course provides individuals, community leaders, and first responders with information on how cyber-attacks can impact, prevent, and/or stop operations and emergency responses in a community. The course also provides a cursory introduction to cybersecurity vulnerabilities, risks, threats, and countermeasures. It explains vulnerabilities of computer systems and networks and how these vulnerabilities can affect communities, organizations, and daily workplace operations.

The course introduces actions communities can take in establishing a cybersecurity program. The course provides participants with an awareness of issues. It gives an overview of threats and vulnerabilities, without going into too many details, to highlight the potential impact a cyber-attack could have. Participants discuss some of the fundamental activities needed to develop a cybersecurity program, without addressing the technical details of how to secure critical infrastructures.

The course introduces the Community Cybersecurity Maturity Model (CCSMM) as a framework for understanding community cybersecurity and offers a brief introduction to low-cost or no-cost approaches to securing a community against cybersecurity threats and attacks. The course sets the stage for further efforts in which a community can build a cybersecurity program.

Objectives:
At the conclusion of the course, participants will be able to:
- Recognize why community cybersecurity is important.
- Recognize the characteristics of a community cybersecurity program.

Target Audience:
Citizen/Community Volunteer, Emergency Management, EMS, Fire Service, Governmental Administrative, Healthcare, Law Enforcement, Private Sector/Corporate Security and Safety Professionals

Prerequisite:
You must be a US Citizen to take this course. If you are not a U.S. citizen, please e-mail oem.training@dhses.ny.gov for further instructions.

All participants must have a FEMA Student Identification (FEMA SID) number. Students can search for their existing/create a new FEMA SID at: https://cdp.dhs.gov/femasid/..

Any and all other prerequisite requirements will be managed by the consortium provider. If any additional prerequisites are required as part of the enrollment process the consortium partner will contact you directly prior to the course.

Completion: Participants who attend all sessions will receive a Certificate of Attendance for the course.
Training Dates
10/19/2023 - 10/19/2023
Prerequisites
Do you require reasonable accommodations in order to attend this course (if you select yes then you will be contacted by our office before the first day of class to discuss further).
Are you a United States citizen?
Registration Dates
06/13/2023 - 09/28/2023
Available Seats
25
Hours
4h 0m
Fee
None Specified
Training Location
24 - Kings County
NYC Emergency Management; Conference Room
165 Cadman Plaza East
Brooklyn, NY  11201
Resources Required
Participants enrolled in an in-person, classroom-based course delivery will need access to a laptop or mobile device/tablet during the class session to complete course testing and evaluations electronically.
Reporting Instructions
1 p.m. to 5 p.m.

Dress is business casual.
Signup Details
No Show Policy: Failure to attend a class you have registered for can result in restriction on future course attendance and agency notification. It is the students responsibility to notify us in a timely manner if you cannot attend.
Warning

Internet Explorer 11 is no longer supported

Acadis® will no longer support Internet Explorer 11. Users who choose to continue using Internet Explorer 11 will not have full Acadis® functionality, which may include broken features that will not be updated for this browser. For the best experience, please switch to a supported browser.

Supported browsers: